GitHub

您所在的位置:网站首页 mikrotik cloud backup GitHub

GitHub

2023-10-30 18:34| 来源: 网络整理| 查看: 265

RouterOS Scripts

GitHub stars GitHub forks GitHub watchers required RouterOS version Telegram group @routeros_scripts donate with PayPal

RouterOS Scripts Logo

RouterOS is the operating system developed by MikroTik for networking tasks. This repository holds a number of scripts to manage RouterOS devices or extend their functionality.

Use at your own risk, pay attention to license and warranty!

Requirements

Latest version of the scripts require recent RouterOS to function properly. Make sure to install latest updates before you begin. If new functionality or a breaking change in RouterOS 7.n is used in my scripts I push my change some time after 7.(n+1) was released. At any time you should have at least two minor and their bugfix releases to choose from.

Specific scripts may require even newer RouterOS version.

鈩癸笍 Info: The main branch is now RouterOS v7 only. If you are still running RouterOS v6 switch to routeros-v6 branch!

Initial setup Get me ready!

If you know how things work just copy and paste the initial commands. Remember to edit and rerun global-config-overlay! First time users should take the long way below.

Live presentation

Want to see it in action? I've had a presentation Repository based RouterOS script distribution including demonstation recorded live at MUM Europe 2019 in Vienna.

鈿狅笍 Warning: Some details changed. So see the presentation, then follow the steps below for up-to-date commands.

The long way in detail

The update script does server certificate verification, so first step is to download the certificates. If you intend to download the scripts from a different location (for example from github.com) install the corresponding certificate chain.

/tool/fetch "https://git.eworm.de/cgit/routeros-scripts/plain/certs/E1.pem" dst-path="letsencrypt-E1.pem";

screenshot: download certs

Note that the commands above do not verify server certificate, so if you want to be safe download with your workstations's browser and transfer the files to your MikroTik device.

ISRG Root X2 Let's Encrypt E1

Then we import the certificates.

/certificate/import file-name=letsencrypt-E1.pem passphrase="";

Do not worry that the command is not shown - that happens because it contains a sensitive property, the passphrase.

screenshot: import certs

For basic verification we rename the certificates and print their count. Make sure the certificate count is two.

/certificate/set name="E1" [ find where common-name="E1" ]; /certificate/set name="ISRG-Root-X2" [ find where common-name="ISRG Root X2" ]; /certificate/print count-only where fingerprint="46494e30379059df18be52124305e606fc59070e5b21076ce113954b60517cda" or fingerprint="69729b8e15a86efc177a57afb7171dfc64add28c2fca8cf1507e34453ccb1470";

screenshot: check certs

Always make sure there are no certificates installed you do not know or want!

All following commands will verify the server certificate. For validity the certificate's lifetime is checked with local time, so make sure the device's date and time is set correctly!

Now let's download the main scripts and add them in configuration on the fly.

:foreach Script in={ "global-config"; "global-config-overlay"; "global-functions" } do={ /system/script/add name=$Script source=([ /tool/fetch check-certificate=yes-without-crl ("https://git.eworm.de/cgit/routeros-scripts/plain/" . $Script . ".rsc") output=user as-value]->"data"); };

screenshot: import scripts

And finally load configuration and functions and add the scheduler.

/system/script { run global-config; run global-functions; }; /system/scheduler/add name="global-scripts" start-time=startup on-event="/system/script { run global-config; run global-functions; }";

screenshot: run and schedule scripts

Scheduled automatic updates

The last step is optional: Add this scheduler only if you want the scripts to be updated automatically!

/system/scheduler/add name="ScriptInstallUpdate" start-time=startup interval=1d on-event=":global ScriptInstallUpdate; \$ScriptInstallUpdate;";

screenshot: schedule update

Editing configuration

The configuration needs to be tweaked for your needs. Edit global-config-overlay, copy relevant configuration from global-config (the one without -overlay). Save changes and exit with Ctrl-o.

/system/script/edit global-config-overlay source;

screenshot: edit global-config-overlay

To apply your changes run global-config, which will automatically load the overlay as well:

/system/script/run global-config;

screenshot: apply configuration

This last step is required when ever you make changes to your configuration.

鈩癸笍 Info: It is recommended to edit the configuration using the command line interface. If using Winbox on Windows OS, the line endings may be missing. To fix this run: /system/script/set source=[ $Unix2Dos [ get global-config-overlay source ] ] global-config-overlay;

Updating scripts

To update existing scripts just run function $ScriptInstallUpdate. If everything is up-to-date it will not produce any output.

$ScriptInstallUpdate;

screenshot: update scripts

If the update includes news or requires configuration changes a notification is sent - in addition to terminal output and log messages.

news and changes notification

Adding a script

To add a script from the repository run function $ScriptInstallUpdate with a comma separated list of script names.

$ScriptInstallUpdate check-certificates,check-routeros-update;

screenshot: install scripts

Scheduler and events

Most scripts are designed to run regularly from scheduler. We just added check-routeros-update, so let's run it every hour to make sure not to miss an update.

/system/scheduler/add name="check-routeros-update" interval=1h on-event="/system/script/run check-routeros-update;";

screenshot: schedule script

Some events can run a script. If you want your DHCP hostnames to be available in DNS use dhcp-to-dns with the events from dhcp server. For a regular cleanup add a scheduler entry.

$ScriptInstallUpdate dhcp-to-dns,lease-script; /ip/dhcp-server/set lease-script=lease-script [ find ]; /system/scheduler/add name="dhcp-to-dns" interval=5m on-event="/system/script/run dhcp-to-dns;";

screenshot: setup lease script

There's much more to explore... Have fun!

Available scripts Find and remove access list duplicates Upload backup to Mikrotik cloud Send backup via e-mail Save configuration to fallback partition Upload backup to server Download packages for CAP upgrade from CAPsMAN Run rolling CAP upgrades from CAPsMAN Renew locally issued certificates Renew certificates and notify on expiration Notify about health state Notify on LTE firmware upgrade Notify on RouterOS update Collect MAC addresses in wireless access list Use wireless network with daily psk Comment DHCP leases with info from access list Create DNS records for DHCP leases Automatically upgrade firmware and reboot Download, import and update firewall address-lists Wait for global functions und modules Send GPS position to server Use WPA2 network with hotspot credentials Create DNS records for IPSec peers Update configuration on IPv6 prefix change Manage IP addresses with bridge status Run other scripts on DHCP lease Manage LEDs dark mode Forward log messages via notification Mode button with multiple presses Manage DNS and DoH servers from netwatch Notify on host up and down Visualize OSPF state via LEDs Manage system update Run scripts on ppp connection Act on received SMS Forward received SMS Play Super Mario theme Chat with your router and send commands via Telegram bot Install LTE firmware upgrade Update GRE configuration with dynamic addresses Update tunnelbroker configuration Available modules Manage ports in bridge Manage VLANs on bridge ports Inspect variables IP address calculation Send notifications via e-mail Send notifications via Matrix Send notifications via Ntfy Send notifications via Telegram Download script and run it once Import ssh keys for public key authentication Installing custom scripts & modules

My scripts cover a lot of use cases, but you may have your own ones. You can still use my scripts to manage and deploy yours, by specifying base-url (and url-suffix) for each script.

This will fetch and install a script hello-world.rsc from the given url:

$ScriptInstallUpdate hello-world "base-url=https://git.eworm.de/cgit/routeros-scripts-custom/plain/";

screenshot: install custom script

For a script to be considered valid it has to begin with a magic token. Have a look at any script and copy the first line without modification.

Starting a script's name with mod/ makes it a module and it is run automatically by global-functions.

Linked custom scripts & modules

鈿狅笍 Warning: These links are being provided for your convenience only; they do not constitute an endorsement or an approval by me. I bear no responsibility for the accuracy, legality or content of the external site or for that of subsequent links. Contact the external site for answers to questions regarding its content.

Hello World (This is a demo script to show how the linking to external documentation will be done.)

鈩癸笍 Info: You have your own set of scripts and/or modules and want these to be listed here? There should be a general info page that links here, and documentation for each script. You can start by cloning my Custom RouterOS-Scripts (or fork on GitHub or GitLab) and make your changes. Then please get in contact...

Removing a script

There is no specific function for script removal. Just remove it from configuration...

/system/script/remove to-be-removed;

screenshot: remove script

Possibly a scheduler and other configuration has to be removed as well.

Contact

We have a Telegram Group RouterOS-Scripts!

RouterOS Scripts Telegram Group

Get help, give feedback or just chat - but do not expect free professional support!

Contribute

Thanks a lot for past contributions! 鉂わ笍

Patches, issues and whishlist

Feel free to contact me via e-mail or open an issue or pull request at github.

Donate

This project is developed in private spare time and usage is free of charge for you. If you like the scripts and think this is of value for you or your business please consider to donate with PayPal.

donate with PayPal

Thanks a lot for your support!

License and warranty

This program is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

Upstream

URL: GitHub.com

Mirror: eworm.de GitLab.com

猬嗭笍 Go back to top



【本文地址】


今日新闻


推荐新闻


CopyRight 2018-2019 办公设备维修网 版权所有 豫ICP备15022753号-3